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FAQs

Providing Solutions to Frequently Asked Questions about QFM and P3rform

FAQ's

How do I install QFM 5 Desktop?

Problem
How do I install QFM 5 Desktop?

Resolution
QFM5 Desktop is installed using install media provided by SWG. For clients who require are large amount of Users on QFM Desktop we would recommend installing QFM Desktop on a terminal server which users can connect to via applications such as Citrix or 2X.

If you are not using a terminal server to host QFM Desktop and you require QFM Desktop a copy will have to be manually installed on your computer.  In this scenario please file a request with your QFM Administrator or contact Support on support@swg.com  for assistance.

Error Message “QFM error 429 – ActiveX component can’t create object” when you attempt to print event related documents or run Start of Day.

Problem
When you attempt to print event related documents or run Start of Day, you may receive an error message that is similar to the following:

“QFM error 429 – ActiveX component can’t create object”

The QFM system may also fail at this point.

Cause
This issue occurs because you do not have the Crystal application installed on your computer.

Resolution
Install either the “Crystal Runtime” or “Patch 145” application.

Error Message “Run-time error ‘429’: ActiveX component can’t create object.” when using Resource Scheduler.

Problem
When using QFM Resource Scheduler, you may receive an error message that is similar to the following:

“Run-time error ‘429’: ActiveX component can’t create object.”

Cause
This issue is due to a defect which has subsequently been fixed and is available in desktop QFM release 162.35.

Resolution
Please contact your SWG account manager to request a QFM upgrade to version 162.35 or later.

Error Message “QFM Error – 2147217904. Procedure ‘qfm_RptLinkedAssets’ expects parameter ‘@EventID’, which was not supplied.” when attempting to print an event worksheet.

Problem
When attempting to print an event worksheet, you may receive an error message that is similar to the following:

“QFM Error – 2147217904. Procedure ‘qfm_RptLinkedAssets’ expects parameter ‘@EventID’, which was not supplied.”

Cause
This issue is due to a defect which has subsequently been fixed and is available in desktop QFM release 162.33.00.05.

Resolution
Please contact your SWG account manager to request a QFM upgrade to version 162.33.00.05 or later.

When I run an Event History Report, events are reported outside of the date range specified.

Problem
When I run an Event History Report, events are reported outside of the date range specified.

Cause
This is due to a defect which has been subsequently fixed.

Resolution
To obtain the fix for this issue, upgrade to desktop QFM version 162.35.01.01 or later.

When I make a long term Accommodation Booking, the Planner applies random gaps in the booking.

Problem
When I make a long term Accommodation Booking, the Planner applies random gaps in the booking.

Cause
This issue is due to a defect which is now subsequently fixed.

Resolution
To obtain the fix for this issue, upgrade to desktop QFM version 164.00.00.05.

Error Message “Database Connection has been lost, please close and restart QFM” when attempting to run Start Of Day.

Problem
When you attempt to run Start Of Day, you may receive an error message that is similar to the following:

“Database Connection has been lost, please close and restart QFM.”

Cause
This could be caused by one of the following reasons:

  1. The server has insufficient memory
  2. Data has been lost on the network

Resolution

  1. Add more memory to the server
  2. Streamline the network
Event Screen – Priority field not being populated.

Problem
When you log an event, the Priority field is not being populated.

Cause
It is likely that you are using the unrestricted ellipsis button, as shown below elipsis to make selections for both the Service and Work Type. The Priority will not automatically populate as an unrestricted selection allows you to add a Priority of your choice.

Resolution
Use the restricted buttons, as shown below restricted only to select the Service and Work Type.

To activate restricted selections follow the steps below:

  1. Log on to QFM as an Admin user.
  2. Go to Applications > Admin > Maintain Classes.
  3. Navigate to the Standard user class.
  4. In the Permissions section (left side) navigate to FM > FM Event then click the blue square next to Event.
  5. In the QFM Parameters section (right side) scroll down until you find the Restricted Service / Service Groups parameter.
  6. In Update mode change the Active setting to On.
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